Вторник
21.11.2017, 02:04
Приветствую Вас Гость | RSS
Главная Каталог статей Регистрация Вход
Меню сайта

Категории раздела
Разное [15]
Документация [18]
Авторские статьи [45]

Поиск

Свежие статьи
Динамическое деление скоро...
port knocking на mikrotik
Установка NGINX без прав R...
Как настроить время (NTP S...
Настраеваем CROND
Биллинг MikBill на UBUNTU
Даунгрейд PHP до версии 5....
Устанавливаем в Ubuntu 10....
Как настроить MySQL
Как настроить ZendOptimize...

Форма входа
Логин:
Пароль:

Главная » Статьи » Документация

OSPF
OSPF
Спецификация
Требуемые пакеты: routing
Требуемый уровень лицензии: Level 3
Уровень подменю: /routing ospf
Стандарты и технологии: OSPF
Аппаратное обеспечение: не принципиально
Cсопровождающие документы
Software Package Management
IP Addresses and ARP
Routes, Equal Cost Multipath Routing, Policy Routing
Log Management
Описание
Open Shortest Path First (первый доступный кратчайший путь) протокол - это протокол
проверки состояния маршр ута. Для построения он использует алгоритм проверки
состояния и вычисляет кратчайший путь ко всем известным пунктам назначения. Для
вычисления кратчайшего пути используется алгоритм Дейкстры. OSPF распределяет
информацию о маршрутах между маршрутизаторами которые принадлежат одиночным
автономным системам(АС). Под автономной системой подразумевается
группа маршрутизаторов обменивающаяся информацией о маршрутах с помощью
обычного протокола маршрутизации.
Для развертывания OSPF необходимо скоординировать наст ройку всех маршрутизаторов
(заметьте это также означает, что все маршрутизаторы участники OSPF должны иметь
одинаковый MTU).
Протокол OSPF стартует после того как вы добавите запись в список OSPF сети. Изучение
маршрутов происходит в соответствии с проток олом OSPF согласно маршрутам
установленным в таблице маршрутизации с количеством прыжков равным 110.
Основные установки
Уровень подменю:/routing ospf
Описание свойств
distribute-default (never | if-installed-as-type-1 | if-installed-as-type-2
| always-as-type-1 | always-as-type-2; default: never) - определяет как распределить маршрут
по умолчанию. Может быть использован для ABR(Область Ограниченная
магшрутизатором) или ASBR(Пограничный маршрутизатор Автономной системы)
установок.
never - не посылать маршрут по умолчанию другим маршрутизаторам
if-installed-as-type-1 - раздавать маршрут по умолчанию с типом метрики 1 только
если он существует(статический маршрут по умолчанию, или маршрут
добавленный в DHCP PPP и.т.д)
if-installed-as-type-2 - раздавать маршрут по умолчанию с типом метрики 2 только
если он существует(статический маршрут или маршрут добавленный в DHCP PPP
и.т.д)
always-as-type-1 - всегда раздавать маршрут по умолчанию с типом метрики 1.
always-as-type-2 - всегда раздавать маршрут по умолчанию с типом метрики 2.
metric-bgp (integer; по умолчанию: 20) - определяет стоимость маршрута изученного
через BGP протокол.
metric-connected (integer; по умолчанию: 20) - определяет стоимость маршрута к
непосредственно подключенной сети (сети находящейся прямо за маршрутизатором).
metric-default (integer; по умолчанию: 1) - определяет стоимость маршрута по умолчанию.
metric-rip (integer; по умолчанию: 20) - определяет стоимость маршрута по умолчанию
изученого через протокол RIP.
metric-static(integer; по умолчанию: 20) - определяет стоимость статических маршрутов.
redistribute-bgp (as-type-1 | as-type-2 | no; по умолчанию: no) - если установлен,
маршрутизатор будет перераздавать информацию о всех активных маршрутах т.е
маршруты к непосредственно доступным сетям.
redistribute-connected(as-type-1 | as-type-2 | no; по умолчанию: no) - если установлен,
маршрутизатор будет перераздавать информацию о всех активных маршрутах
т.е маршруты к непосредственно доступным сетям.
redistribute-rip (as-type-1 | as-type-2 | no; по умолчанию: no) - при включении этой
возможности маршрутизатор будет перераздавать информацию о всех изученных
маршрутах по протоколу RIP.
redistribute-static (as-type-1 | as-type-2 | no; по умолчанию: no) - если установлен,
маршрутизатор будет перераздавать информацию о всех статических маршрутах
добавленных в его базу данных маршрутизации, т.е., для маршрутов которые должны
быть созданы используйте команду /ip route add.
router-id(IP address; по умолчанию: 0.0.0.0) - OSPF идентификатор маршрути затора. Если
не определен, OSPF в качестве идентификатора использует полный IP адрес
маршрутизатоа.
Примечание
В пределах одной области (одной подсети), только маршрутизатор подключается к другой
области (т.е пограничный маршрутизатор) или к другой AS(т.е м аршрутизатор
граничащий с другой Автономной системой) распространяя установленный маршрут по
умолчанию.
Протокол OSPF будет пытаться использовать кратчайший путь (с минимальной
стоимостью) если возможно.
Протокол OSPF поддерживает два типа метрик:
type1 - внешнии метрики, выражаются в некоторых единицах как стоимость OSPF
интерфейса. Другими словами маршрутизатор предполагает что стоимость
внешнего соединения к AS может быть представлена такой же величиной как и
внутреннее соединение.
type2 - внешнии метрики, с большим порядком величин; дугой type2 метрик
предполагает использование более длинного пути с небольшой стоимостью к
внешним AS. Используйте type2 внешнюю метрику для тех маршрутов между AS у
которых главным критерием является стоимость маршрутизации пакета.
Оба типа внешних метрик и Type1 и Type2 могут быть использованы в AS попеременно. В
этом случае, Type1 внешних метрик всегда должен стартовать первым.
В /ip route вы можете просмотреть маршруты со статусом Io. Потому что маршрутизатор
получает маршруты от себя.
Стоимость метрики может быть получена из скорости передачи по формуле
10e+8/скорость передачи. Ниже представленная таблица включающая несколько
примеров:
тип сети
стоимость
ethernet 10
T1 64
64Kb/s 1562
Пример
Для включения OSPF протокола перераспределения маршрутов к подключенной сети как
type1 со стоимостью 1 вам необходимо сделать следующее.
[admin@MikroTik] routing ospf> set redistribute-connected=as-type-1
... metric-connected=1
[admin@MikroTik] routing ospf> print
router-id: 0.0.0.0
distribute-default: never
redistribute-connected: as-type-1
redistribute-static: no
redistribute-rip: no
redistribute-bgp: no
metric-default: 1
metric-connected: 1
metric-static: 20
metric-rip: 20
metric-bgp: 20
[admin@MikroTik] routing ospf>
Области
Уровень подменю: /routing ospf area
Описание
OSPF собирает информацию с маршрутизаторов которые сгруппированные вместе. Такая
группировка называется область. каждая область стартует с отдельной копией (состояния
соединения) базового алгоритма марш рутизации. Это означает, что каждая область имеет
свою собственную базу данных состояний соединений и соответствующий граф.
Структура области не видима снаружи. Эта изоляция позволяет протоколу значительно
сократить маршрутизацию трафика по сравнению с тем как если бы вся Автономная
система рассматривалась как единое соединение.
В пределах одной области не должно быть более 60 -80 маршрутизаторов.
Описание свойств
area-id(IP address; по умолчанию: 0.0.0.0) - идентификатор OSPF области. По умолчанию
area-id=0.0.0.0 - основная области. Основная OSPF область всегда включает в себя все
пограничные маршрутизаторы. Основа ответственна за распределение информации между
не основными областями. Основа должна быть смежной (не изолирована от не основ).
Однако области не должны быть физически подсоединены к основе. Это возможно
сделать путем создания виртуальных соединений. Название и идентификатор области не
могут быть изменены.
authetication(none | simple | md5; по умолчанию: none) - метод аутентификации для
передачи сообщений по протоколу OSPF
none - не использовать аутентификацию
simple - аутентификация открытым текстом
md5 - аутентификация с помощью md5
default-cost(integer; по умолчанию: 1) - определенная по умолчанию стоимость для не
основных областей. применимо только для областей граничащих с маршрутизатором.
name(name; по умолчанию "") - название OSPF области.
stub(yes | no; по умолчанию: no) - не основная(обрезок) область это область которая не
имеет маршрутов к АС или находится вне зоны действия областей.
Не основная область формируется так чтобы избежать запросов идущих от АС к этой
области, как если бы это было внешнее соединение к основной области. Одна из причин
создание не основных областей это уменьшение базы данных состояний маршрутов и
уменьшение тем самым количество циклов CPU на обработку этих данных. Другие
маршрутизаторы которые пытаются получить доступ к внешней сети посылают пакеты
через шлюз по умолчанию.
Пример
Для определения дополнительной OSPF области с именем local_10 с area-id=0.0.0.15
выполните следующее:
[admin@WiFi] routing ospf area > add area-id=0.0.10.5 name=local_10
[admin@WiFi] routing ospf area > print
Flags: X - disabled, I - invalid
# NAME
AREA-ID
STUB DEFAULT-COST AUTHENTICATION
0
backbone
0.0.0.0
1
local_10
0.0.10.5
[admin@WiFi] routing ospf area >
no
1
none
none
Сети
Уровень подменю: /routing ospf network
Описание
Возможно два типа объединения сетей это Точка -Точка или Мультидоступ. Сети с
мультидоступом могут быть широковещательными сетями(т.е одиночное сообщение
может быть разослано всем маршрутизаторам). Для запуска OSPF протокола, вам
необходимо определить сеть где он (протокол) будет запущен и идентификатор области
для каждой из этих сетей.
Cвойство описания
area(name; по умолчанию: backbone) - OSPF область ассоциированная с выбранным
диапазоном адресов.
network(IP адрес маска; по умолчанию: 20) - сеть ассоциированная с областью. Аргумент
networks позволяет определить один или multiple интерфейсы, которые связаны с
определенной областью OSPF.
Замечание
Вам необходимо будет установить сетевой адрес точно также как для соединения точка -
точка. Правильная сетевая маска в этом случае /32.
Пример
Для включения протокола OSPF в сети 10.10.1.0/24, и включения его в основную область
выполните следующее:
[admin@MikroTik] routing ospf network > add area=backbone network=10.10.1.0/24
[admin@MikroTik] routing ospf network > print
Flags: X - disabled
# NETWORK
AREA
0
10.10.1.0/24
backbone
[admin@MikroTik] routing ospf>
Интерфейсы
Уровень подменю:/routing ospf interface
Описание
Это средство предоставляет возможность для конфигурирования дополнительных
параметров OSPF интерфейсов.
Описание свойств
authentication-key (text; по умолчанию: "") - ключ аутентификации который может быть
использован соседними маршрутизаторами использующими простую аутентификацию.
cost(integer: 1..65535; по умолчанию: 1) - стоимость интерфейса выраженная как метрика
состояния соединения.
dead-interval(time; по умолчанию:40s) - временной интервал по истечении которого
соседний маршрутизатор классифицируется как мертвый. Интервал рассылается в пакете
hello. Это значение должно быть одинаково для всех маршрутизаторов и досту пно им.
hello-interval (time; по умолчанию 10s) - интервал между пакетами hello которые
маршрутизатор посылает через интерфейс. Чем меньше интервал, тем быстрее будут
обнаружены изменения топологии сети, но при этом сильно увеличится трафик. Это
значение должно быть одинаково на обоих концах иначе они не синхронизируются.
interface(name; по умолчанию: all) - интерфейс на котором будет запущен OSPF
all - если включено, то интерфейсы не имеют других специфичных установок
priority(integer: 0..255; по умолчанию:1) - приоритет маршрутизатора. Это параметр
помогает определить главный(приоритетный) маршрутизатор для сети. Когда два
маршрутизатора присоединенных к сети претендуют на место приоритетного, тот у кого
приоритет выше становится главным.
retransmit-interval(time; по умолчанию: 5s) - интервал перераздачи информации о
потерянных соединениях. Когда маршрутизатор посылает объявления о состоянии
соединения(LSA) своим соседям, он содержит в себе предыдущий LSA до тех пор пока не
получит ответ. Если маршрути затор не получит ответа вовремя он будет продолжать
раздавать старый LSA. Рекомендуются следующие установки: для широковещательных 5
секунд и для точка-точка 10 секунд.
transmit-delay(time; по умолчанию: 1s) - задержка передачи информации о состоянии
соединения на предполагаемое время необходимое для передачи пакета обновления о
состоянии интерфейса.
Пример
Дл добавления свойство с помощью которого интерфейс ether2 будет посылать пакет
Hello каждые 5 секунд, выполните следующее:
[admin@MikroTik] routing ospf> interface add interface=ether2 hello-
interval=5s
[admin@MikroTik] routing ospf> interface print
0 interface=ether2 cost=1 priority=1 authentication-key=""
retransmit-interval=5s transmit-delay=1s hello-interval=5s
dead-interval=40s
[admin@MikroTik] routing ospf>
Виртуальные соединения
Уровень подменю: /routing ospf virtual-link
Описание
В RFC к OSPF сказано что основные области должны быть смежными. Однако возможно
определить области таким образом, что они не будут смежены. В этом случае системный
администратор должен восстановить основные соединения путем конфигурирования
виртуальных соединений. Виртуальные соединения могут быть сконфигурированы между
двумя маршрутизаторами через общую область объявленную как транзитная область, это
один из возможных вариантов сое динения с основной областью. Виртуальные соединения
должны принадлежать основной области. Протокол рассматривает два маршрутизатора
объединенных через виртуальное соединение так, как если бы они были объединены
непронумерованным соединением точка-точка.
Описание свойств
neighbor-id(IP address; по умолчанию: 0.0.0.0) router-id соседнего маршрутизатора.
transit-area(name; по умолчанию: (unknown)) - не основная область, которую используют
два маршрутизатора
Примечание
Виртуальные соединения не могут быть уст ановлены через не основную (обрезок) зону.
Пример
Для добавления виртуального соединения с маршрутизатором 10.0.0.201 через область ex,
выполните следующее:
[admin@MikroTik] routing ospf virtual-link> add neighbor-id=10.0.0.201
... transit-area=ex
[admin@MikroTik] routing ospf virtual-link> print
Flags: X - disabled, I - invalid
# NEIGHBOR-ID
TRANSIT-AREA
0
10.0.0.201
ex
[admin@MikroTik] routing ospf virtual-link>
Виртуальные соединения должны быть сконфигурированы на обоих маршрутизатор ах.
Соседи
Уровень подменю: /routing ospf neigbor
Описание
Данное подменю предоставляет доступ к списку OSPF соседей, то есть маршрутизаторы
смежные с текущим маршрутизатром и обменивающиеся с ним статистикой.
Описание свойств
address(read-only: IP адрес) - соответствующий IP адрес соседа.
backup-dr-id(read-only: IP адрес) - сделать копию маршрутов маршрутизатора для этого
маршрутизатора.
db-summaries(read-only: integer) - номер записи в базе данных состояний соединений
розданных соседом.
dr-id(read-only: IP адрес) - определенный маршрутизатором маршрут для этого соседа.
ls-request(read-only: integer) - номера запрошенных состояний соединений
ls-retransmits(read-only: integer) - номера повторно переданных состояний соединений.
priority(read-only: integer) - приоритет соседа который используется при выборе маршрута
через протокол Hello в этой сети
router-id(read-only: IP адрес) - router-id параметры соседа
state(read-only: Down | Attempt | Init | 2 -Way | ExStart | Exchange | Loading | Full) - coстояние
соединения:
Down - соединение утеряно
Attempt - маршрутизатор посылает пакеты Hello
Init - обмен пакетами Hello между маршрутизаторами для создания соседских
отношений
2-Way - маршрутизаторы добавляют друг друга в свои базы данных, после чего
они становятся соседями
ExStart - DR (Весдущий маршрутизатор) и BDR(Ведущий ре зервный
маршрутизатор) создают друг с другом дружественные отношения, а затем создают
базу данных состояния соединений используя базу данных описаний пакетов.
Exchange - процесс обнаружения маршрутов или обмен базами данных описания
пакетов
Loading - получение информации от соседа
Full - базы данных состояний соединений полностью синхронизированы.
Маршрутизаторы маршрутизируют трафик и обмениваются друг с другом
пакетами Hello, для поддержания соседства и обмена информации о маршрутах
state-changes(read-only: integer) - номер соединения подавшего заявку на изменение
Примечание
Список соседей также отображает сам маршрутизатор с двумя состояниями соединений
Пример
Приведенный ниже листинг может быть применен для исследования после добавления
OSPF сети:
admin@MikroTik] routing ospf> neighbor print
router-id=10.0.0.204 address=10.0.0.204 priority=1 state="2-Way"
state-changes=0 ls-retransmits=0 ls-requests=0 db-summaries=0
dr-id=0.0.0.0 backup-dr-id=0.0.0.0
[admin@MikroTik] routing ospf>
Прикладные примеры
OSPF резервное копирование без использования туннеля
Предположим что наша связь между маршрутизаторами выглядит так OSPF -Main и OSPF-
peer-1 ведущий. Если это соединение падает то мы хотим чтобы трафик шел через OSPF-
peer-2. Этот пример показывает, как использовать OSPF в резервных целях, если
контролируете все маршрутизаторы, можете запустить OSPF на них.
Для этого необходимо сделать следующее:
1. Заводим OSPF область с ID=0.0.0.1, которая включает в себя все три маршрутизатора
показанных на рисунке
2. Толко главный OSPF маршрутизатор будет иметь маршруты по умолчанию. Его
интерфейсы peer1 и peer2 будут сконфигурированы для OSPF протокола. Интерфейс
main_gw не будет использоваться для раздачи OSPF маршрутов
3. Маршрутизаторы OSPF -peer-1 и OSPF-peer-2 будут раздавать информацию об их
соединениях, и получать маршруты по умолчанию используя протокол OSPF.
Тепрь займемся установкой маршрутизатора .
Маршрутизатор имеет три интерфейса
[admin@OSPF_MAIN] interface> print
Flags: X - disabled, D - dynamic, R - running
# NAME
0 R main_gw
 0
R to_peer_1
0
R to_peer_2
0
1
2
TYPE
RX-RATE
TX-RATE
MTU
ether 0
ether 0
ether 0
1500
1500
1500
Добавляем указанные ip адреса, как указано ниже
[admin@OSPF_MAIN] ip address> print
Flags: X - disabled, I - invalid, D - dynamic
#
ADDRESS
0
192.168.0.11/24
1
10.1.0.2/24
to_peer_1
2
10.2.0.2/24
to_peer_2
NETWORK
BROADCAST
INTERFACE
192.168.0.0 192.168.0.255
10.1.0.0 10.1.0.255
10.2.0.0
main_gw
10.2.0.255
Вы должны установить параметр distribute-default в if-installed-as-type-2, а параметр
redistribute-connected в as-type-1 и redistribute-static в as-type-2.
Metric-connected, metric-static, metric-rip, metric-bgp должны быть сброшены.
[admin@OSPF_MAIN] routing ospf> print
router-id: 0.0.0.0
distribute-default: if-installed-as-type-2
redistribute-connected: as-type-1
redistribute-static: as-type-2
redistribute-rip: no
redistribute-bgp: no
metric-default: 1
metric-connected: 0
metric-static: 0
metric-rip: 0
metric-bgp: 0
Определим новую OSPF область local_10 с area -id 0.0.0.1:
[admin@OSPF_MAIN] routing ospf area > print
Flags: X - disabled, I - invalid
# NAME
AUTHENTICATION
0
1
AREA-ID
STUB DEFAULT-COST
backbone
none
local_10
none
0.0.0.0
0.0.0.1
no
1
Добавим соединенные сети с area local_10 в OSPF сеть:
[admin@OSPF_MAIN] routing ospf network > print
Flags: X - disabled, I - invalid
#
0
1
NETWORK
AREA
10.1.0.0/24
10.2.0.0/24
local_10
local_10
На этом конфигурирование главного маршрутизатора окончено. Далее необходимо
настроить маршрутизатор OSPF_peer_1.
Включим следующие интерфейсы в OSPF_peer_1:
[admin@OSPF_peer_1] interface> print
Flags: X - disabled, D - dynamic, R - running
# NAME
0 R backup
 0
R to_main
0
1
TYPE
RX-RATE
TX-RATE
MTU
ether 0
ether 0
1500
1500
Присвоим IP адреса к этим интерфейсам:
[admin@OSPF_peer_1] ip address> print
Flags: X - disabled, I - invalid, D - dynamic
#
ADDRESS
NETWORK
0
10.1.0.1/24
to_main
1
10.3.0.1/24
BROADCAST
INTERFACE
10.1.0.0 10.1.0.255
10.3.0.0 10.3.0.255
backup
Установим параметр redistribute-connected в as-type-1. Metric-connected, metric-static,
metric-rip, metric-bgp должны быть установлены в ноль.
[admin@OSPF_peer_1] routing ospf> print
router-id: 0.0.0.0
distribute-default: never
redistribute-connected: as-type-1
redistribute-static: no
redistribute-rip: no
redistribute-bgp: no
metric-default: 1
metric-connected: 0
metric-static: 0
metric-rip: 0
metric-bgp: 0
Добавим эту область в главный маршрутизатор
[admin@OSPF_peer_1] routing ospf area > print
Flags: X - disabled, I - invalid
# NAME
AUTHENTICATION
0
1
AREA-ID
backbone
none
local_10
none
STUB DEFAULT-COST
0.0.0.0
0.0.0.1
no
1
Добавим соединение сетей с областью local_10:
[admin@OSPF_peer_1] routing ospf network > print
Flags: X - disabled, I - invalid
#
0
1
NETWORK
10.3.0.0/24
10.1.0.0/24
AREA
local_10
local_10
В заключении, настроим настроим OSPF_peer2. Включим следующие интерфейсы:
[admin@OSPF_peer_2] interface> print
Flags: X - disabled, D - dynamic, R - running
#
NAME
TYPE
RX-RATE
TX-RATE
MTU
0
R to_main
0
R to_peer_1
0
1
ether 0
ether 0
1500
1500
Пропишем необходимые IP адреса:
[admin@OSPF_peer_2] ip address> print
Flags: X - disabled, I - invalid, D - dynamic
#
ADDRESS
NETWORK
0
10.2.0.1/24
to_main
1
10.3.0.2/24
to_peer_1
BROADCAST
INTERFACE
10.2.0.0 10.2.0.255
10.3.0.0 10.3.0.255
Добавим туже область как в предыдущих маршрутизаторах:
[admin@OSPF_peer_2] routing ospf area > print
Flags: X - disabled, I - invalid
# NAME
AUTHENTICATION
0
AREA-ID
backbone
none
local_10
none
1
STUB DEFAULT-COST
0.0.0.0
0.0.0.1
no
1
Добавим соединение сетей с этой областью:
[admin@OSPF_peer_2] routing ospf network > print
Flags: X - disabled, I - invalid
#
NETWORK
0
1
10.2.0.0/24
10.3.0.0/24
AREA
local_10
local_10
После того, как все маршрутизаторы были настроены , как описано выше, и соединения
между ними заработало, таблицы маршрутизации на всех трех маршрутизаторах должны
выглядеть следующим образом:
[admin@OSPF_MAIN] ip route> print
Flags: X - disabled, I - invalid, D - dynamic, J - rejected,
C - connect, S - static, r - rip, o - ospf, b - bgp
#
DST-ADDRESS
0 Io 192.168.0.0/24
1 DC 192.168.0.0/24
2 Do 10.3.0.0/24
3
4
5
6
Io
DC
Io
DC
10.2.0.0/24
10.2.0.0/24
10.1.0.0/24
10.1.0.0/24
G GATEWAY
110
r 0.0.0.0
r 10.2.0.1
r 10.1.0.1
110
r 0.0.0.0
110
r 0.0.0.0
DISTANCE INTERFACE
0 main_gw
110 to_peer_2
   to_peer_1
0 to_peer_2
0 to_peer_1
[admin@OSPF_peer_1] ip route> print
Flags: X - disabled, I - invalid, D - dynamic, J - rejected,
C - connect, S - static, r - rip, o - ospf, b - bgp
# DST-ADDRESS G GATEWAY DISTANCE INTERFACE
0 Do 192.168.0.0/24 r 10.1.0.2 110 to_main
1 Io 10.3.0.0/24 110
2 DC 10.3.0.0/24 r 0.0.0.0 0 backup
3 Do 10.2.0.0/24 r 10.1.0.2 110 to_main
r 10.3.0.2 backup
4 Io 10.1.0.0/24 110
5 DC 10.1.0.0/24 r 0.0.0.0 0 to_main
[admin@OSPF_peer_2] ip route> print
Flags: X - disabled, I - invalid, D - dynamic, J - rejected,
C - connect, S - static, r - rip, o - ospf, b - bgp
#
0
1
2
3
4
5
DST-ADDRESS
Do
Io
DC
Io
DC
Do
192.168.0.0/24
10.3.0.0/24
10.3.0.0/24
10.2.0.0/24
10.2.0.0/24
10.1.0.0/24
G GATEWAY
r 10.2.0.2
110
r 0.0.0.0
110
r 0.0.0.0
r 10.3.0.1
r 10.2.0.2
DISTANCE INTERFACE
110 to_main
0 to_peer_1
0 to_main
110 to_peer_1
   to_main
Таблица маршрутизации с учетом стоимости соединения
Данный пример демонстрирует как установить стоимость соединения. Допустим у нас
есть соединение между маршрутизаторами OSPF_peer_1 и OSPF_peer_2 которое имеет
наивысшую стоимость (например оно медленное, или слишком высока оплата за трафик
через это соединение и.т.д).
Мы должны изменить значение стоимости на обоих маршрутизаторах: OSPF_peer_1 и
OSPF_peer_2 на 50. Чтобы это сделать, нам необходимо добавить следующие
интерфейсы:
[admin@OSPF_peer_1] routing ospf interface> add interface=backup cost=50
[admin@OSPF_peer_1] routing ospf interface> print
0 interface=backup cost=50 priority=1 authentication-key=""
retransmit-interval=5s transmit-delay=1s hello-interval=10s
dead-interval=40s
[admin@OSPF_peer_2] routing ospf interface> add interface=to_peer_1 cost=50
[admin@OSPF_peer_2] routing ospf interface> print
0 interface=to_peer_1 cost=50 priority=1 authentication-key=""
retransmit-interval=5s transmit-delay=1s hello-interval=10s
dead-interval=40s
После изменения стоимости, мы имеем только одну присвоенную стоимость multi
маршруту к сети 10.3.0.0/24 от маршрутизатора OSPF_MAIN
Таблица маршрутизации OSPF_MAIN
[admin@OSPF_MAIN] ip route> print
Flags: X - disabled, I - invalid, D - dynamic, J - rejected,
C - connect, S - static, r - rip, o - ospf, b - bgp
#
DST-ADDRESS
0 Io 192.168.0.0/24
1 DC 192.168.0.0/24
2 Do 10.3.0.0/24
3
4
5
6
Io
DC
Io
DC
10.2.0.0/24
10.2.0.0/24
10.1.0.0/24
10.1.0.0/24
G GATEWAY
DISTANCE INTERFACE
110
r 0.0.0.0
r 10.2.0.1
r 10.1.0.1
110
r 0.0.0.0
110
r 0.0.0.0
0 main_gw
110 to_peer_2
   to_peer_1
0 to_peer_2
0 to_peer_1
Таблица маршрутизации OSPF_peer_1
[admin@OSPF_peer_1] > ip route pr
Flags: X - disabled, I - invalid, D - dynamic, J - rejected,
C - connect, S - static, r - rip, o - ospf, b - bgp
#
DST-ADDRESS
G GATEWAY
DISTANCE INTERFACE
0 Do 192.168.0.0/24 r 10.1.0.2 110 to_main
1 Io 10.3.0.0/24 110
2 DC 10.3.0.0/24 r 0.0.0.0
0 backup
3 Do 10.2.0.0/24 r 10.1.0.2 110 to_main
4 Io 10.1.0.0/24 110
5 DC 10.1.0.0/24 r 0.0.0.0
0 to_main
Таблица маршрутизации OSPF_peer_2
[admin@OSPF_peer_2] > ip route print
Flags: X - disabled, I - invalid, D - dynamic, J - rejected,
C - connect, S - static, r - rip, o - ospf, b - bgp
#
DST-ADDRESS
0 Do 192.168.0.0/24
G GATEWAY
r 10.2.0.2
DISTANCE INTERFACE
110
to_main
1
2
3
4
5
Io
DC
Io
DC
Do
10.3.0.0/24
10.3.0.0/24
10.2.0.0/24
10.2.0.0/24
10.1.0.0/24
110
r 0.0.0.0
110
r 0.0.0.0
r 10.2.0.2
0 to_peer_1
0 to_main
110 to_main
Функционирование резервного копирования
Если соединение между маршрутизаторами OSPF_MAIN и OSPF_peer_1 завалится, мы
окажемся в следующей ситуации:
OSPF маршрутизация изменится следующим образом:
Таблица маршрутизации в OSPF_MAIN
[admin@OSPF_MAIN] ip route> print
Flags: X - disabled, I - invalid, D - dynamic, J - rejected,
C - connect, S - static, r - rip, o - ospf, b - bgp
#
0
1
2
3
4
5
6
DST-ADDRESS
Io
DC
Do
Io
DC
Io
DC
192.168.0.0/24
192.168.0.0/24
10.3.0.0/24
10.2.0.0/24
10.2.0.0/24
10.1.0.0/24
10.1.0.0/24
G GATEWAY
110
r 0.0.0.0
r 10.2.0.1
110
r 0.0.0.0
110
r 0.0.0.0
DISTANCE INTERFACE
0 main_gw
110 to_peer_2
0 to_peer_2
0 to_peer_1
Таблица маршрутизации в OSPF_peer_1
[admin@OSPF_peer_1] ip route> print
Flags: X - disabled, I - invalid, D - dynamic, J - rejected,
C - connect, S - static, r - rip, o - ospf, b - bgp
#
0
1
2
3
4
5
DST-ADDRESS
Do
Io
DC
Do
Io
DC
192.168.0.0/24
192.168.0.0/24
10.3.0.0/24
10.2.0.0/24
10.1.0.0/24
10.1.0.0/24
G GATEWAY
r 10.3.0.2
110
r 0.0.0.0
r 10.3.0.2
110
r 0.0.0.0
DISTANCE INTERFACE
110 backup
0 backup
110 backup
0 to_main
Таблица маршрутизации в OSPF_peer_2
[admin@OSPF_peer_2] ip route> print
Flags: X - disabled, I - invalid, D - dynamic, J - rejected,
C - connect, S - static, r - rip, o - ospf, b - bgp
#
0
1
2
3
4
5
DST-ADDRESS
Do
Io
DC
Io
DC
Do
192.168.0.0/24
10.3.0.0/24
10.3.0.0/24
10.2.0.0/24
10.2.0.0/24
10.1.0.0/24
G GATEWAY
r 10.2.0.2
110
r 0.0.0.0
110
r 0.0.0.0
r 10.2.0.2
DISTANCE INTERFACE
110 to_main
0 to_peer_1
0 to_main
110 to_main
Изменения маршрутов происходит приблизительно через 40 секунд (установки hello-
interval). Если необходимо, эти установки могут быть изменены, но это должно быть
сделано на всех маршрутизаторах в пределах области.

Спонсоры данной статьи


Категория: Документация | Добавил: -=shurf=- (26.07.2010)
Просмотров: 9682 | Рейтинг: 1.0/1

Настройка Mikrotik
Серверные сценарии ч.1
Mikrotik - лучший роутер для р...
Динамическое деление скорости ...
Mikrotik и VLAN
Подключаем Mikrotik к Internet...
RouterOS на офисном шлюзе, час...
port knocking на mikrotik
Списки адресов
Списки адресов
MikroTik RouterOS – CommandLin...

Всего комментариев: 0
Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход ]
Профиль
Привет: Гость

Сообщения:

Гость, мы рады вас видеть. Пожалуйста зарегистрируйтесь или войдите!

Реклама

Наш опрос
Нужен ли этому сайту форум?
Всего ответов: 55

Нашел ошибку?
Система Orphus

Статистика

Онлайн всего: 2
Гостей: 2
Пользователей: 0



Бесплатный хостинг uCoz