Вторник
21.11.2017, 02:04
Приветствую Вас Гость | RSS
Главная Каталог статей Регистрация Вход
Меню сайта

Категории раздела
Разное [15]
Документация [18]
Авторские статьи [45]

Поиск

Свежие статьи
Динамическое деление скоро...
port knocking на mikrotik
Установка NGINX без прав R...
Как настроить время (NTP S...
Настраеваем CROND
Биллинг MikBill на UBUNTU
Даунгрейд PHP до версии 5....
Устанавливаем в Ubuntu 10....
Как настроить MySQL
Как настроить ZendOptimize...

Форма входа
Логин:
Пароль:

Главная » Статьи » Документация

MikroTik RouterOS – настройка в CommandLine Interface - PPPoE Client (ADSL) (DHCP client), NAT , DNS, DHCP, VPN server
MikroTik RouterOS – настройка в CommandLine Interface - PPPoE Client (ADSL)
(DHCP client), NAT , DNS, DHCP, VPN server
В данной статье мы рассмотрим типичную задачу для многих офисов, а именно:
используя операционную систему Mikrotik RouterOS, подключим наш офис к интернету
через PPPoE соединение, запустим инетренет в сеть используя NAT, настроим DHCP
сервер для раздачи адресов внутри локальной сети, и настроим VPN сервер для того что бы
мы могли уделено имеет доступ в нашу локальную с еть (обслуживать локальных станций,
сервера ...)
На все это нам потребуется максимум 5-10 минут, приступим ..
1. Смотрим наши сетевые интерфейсы:
/ interface
[admin@MikroTik] interface> print
Flags: X - disabled, D - dynamic, R - running
# NAME
TYPE
RX -RATE TX-RATE
0 R ether0
ether
0
0
1500
1 R ether1
ether
0
0
1500
MTU
Видим что у нас 2 сетевых интерфейса, для удобства можем переименовать их в LAN
интерфейс, смотрящий в нашу локальную сеть и WAN интерфейс, смотрящий в глобальную
сеть( если вас устраивает название ether(n) и вы не будете путаться, то можете пропустить
данный пункт, но тогда не забудьте вместо LAN и WAN писать Ether0 и Ether1).
/ interface address
set 0 name="LAN" disabled=no
set 1 name="WAN" disabled=no
смотрим что получилось:
/ interface
[admin@MikroTik] interface> print
Flags: X - disabled, D - dynamic, R - running
# NAME
TYPE
RX -RATE TX-RATE
0 R LAN
ether
0
0
1500
1 R WAN
ether
0
0
1500
MTU
2. Присваиваем IP адрес локальному интерфейсу:
/ ip address
add address= 192.168.0.1/24 interface=LAN
3. Настраиваем DHCP сервер:
Создаем пул (диапазон) раздаваемых IP адресов:
/ ip pool
add name="dhcp_pool1" ranges=192.168.0.2-192.168.0.254
Настраиваем сам DHCP сервер:
/ ip dhcp-server
add name="dhcp1" interface=LAN address-pool=dhcp_pool1 disabled=no
Что будет присваиваться клиентам:
/ ip dhcp-server network
add address=192.168.0.0/24 gateway=192.168.0.1 dns-server=192.168.0.1
4. * Настраиваем DNS: ( *не обязательно так как при создании PPPoE соединения или
используя DHCP client , можно dns получить автоматически так же как и шлюз по
умолчанию, что и будет показано в примере ниже, однако если вы хотите что бы ваш
сервер был "DNS сервером” то не забудьте все же указать это в настройках : allow-
remote-requests=yes )
/ip dns
set primary-dns=212.0.200.1 secondary-dns=212.0.200.2 allow-remote-requests=yes
Вместо DNS серверов 212.0.200.1 и 212.0.200.2 указываете DNS сервера своего провайдера
Если есть потребность добавить статичес кий адрес какому либо хосту то:
/ ip dns static
add name= "www.myweb.com" address=192.168.0.2
В данном примере при запросе сайта www.myweb.com запрос будет направлен на
внутренний адрес.
5. Создаем PPPoE соединение:
/ interface pppoe-client
add name="pppoe-out1" interface=WAN user="test"
use-peer-dns=yes disabled=no
password="test" add-default-route=yes
Если у вас не PPPoE соединение, а IP раздается DHCP сервером, то вы в место
создания PPPoE соединения создайте DHCP Client:
/ip dhcp-client
add interface=WAN use-peer-dns=yes add-default-route=yes disabled=no
6. Даем доступ из локальной сети в интернет по средствам NAT:
/ip firewall nat
add chain=srcnat out-interface=pppoe-out1 action=masquerade
соответственно если у вас dhcp client, а не pppoe – то будет другой out-interface=WAN
7. Настраиваем VPN server (PPTP):
/interface pptp-server server
set enabled=yes
Добавляем пользователя:
/ppp secret
add name=user password=pass local-address=10.0.0.1 remote-address=10.0.0.2
Вот и все!!!

Спонсоры данной статьи


Категория: Документация | Добавил: -=shurf=- (28.07.2010)
Просмотров: 11111 | Рейтинг: 0.0/0

Настройка Mikrotik
NAT
Защита mikrotik от внешних вто...
RouterOS на офисном шлюзе, час...
Динамическое деление скорости ...
Mikrotik - лучший роутер для р...
Серверные сценарии ч.2
Настраиваем биллинг UTM с Mikr...
OSPF
Примеры установки MikroTiK Rou...
Mikrotik. Манипуляции с DNS. Д...

Всего комментариев: 0
Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход ]
Профиль
Привет: Гость

Сообщения:

Гость, мы рады вас видеть. Пожалуйста зарегистрируйтесь или войдите!

Реклама

Наш опрос
Вы нашли на сайте нужную информацию?
Всего ответов: 55

Нашел ошибку?
Система Orphus

Статистика

Онлайн всего: 3
Гостей: 3
Пользователей: 0



Бесплатный хостинг uCoz