Вторник
21.11.2017, 02:04
Приветствую Вас Гость | RSS
Главная Каталог статей Регистрация Вход
Меню сайта

Категории раздела
Разное [15]
Документация [18]
Авторские статьи [45]

Поиск

Свежие статьи
Динамическое деление скоро...
port knocking на mikrotik
Установка NGINX без прав R...
Как настроить время (NTP S...
Настраеваем CROND
Биллинг MikBill на UBUNTU
Даунгрейд PHP до версии 5....
Устанавливаем в Ubuntu 10....
Как настроить MySQL
Как настроить ZendOptimize...

Форма входа
Логин:
Пароль:

Главная » Статьи » Авторские статьи

RouterOS на офисном шлюзе, часть 3
RouterOS на офисном шлюзе, часть 4: DHCP и DNS

RouterOS на офисном шлюзе, часть 3: Раздача

Итак, мы имеем на руках miniROUTER с последней версией операционной системы на борту и офис с сотрудниками, прямо-таки жаждущими доступа в интернет. Давайте организуем «счастье для всех, даром», т. е. просто раздадим всем клиентам все, что предоставляет нам провайдер.

Условимся называть «красным» порт маршрутизатора, подключенный к сети провайдера, «зеленым» – к локальной сети офиса. В качестве «красного» мы всегда будем использовать порт ether5, в качестве «зеленого» – ether4.

Прямое подключение

Предположим, что при подключении к интернету провайдер выдал нам такие параметры:

  • IP-адрес: 213.180.204.8,
  • Маска: 255.255.255.240 (или /28),
  • Шлюз: 213.180.204.1,
  • DNS-серверы: 194.85.61.20, 193.232.130.14.

Настройка этих параметров на маршутизаторе тривиальна:

/ip address add interface="ether5" address="213.180.204.8/28"
/ip route add gateway="213.180.204.1"
/ip dns set primary-dns="194.85.61.20"
/ip dns set secondary-dns="193.232.130.14"

и сразу после их установки непосредственно на маршрутизаторе будет доступ в интернет, в чем можно легко убедиться:

/ping intacta.ru
195.208.0.16 64 byte ping: ttl=55 time=24 ms
195.208.0.16 64 byte ping: ttl=55 time=8 ms
195.208.0.16 64 byte ping: ttl=55 time=36 ms
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 8/22.6/36 ms

Теперь позаботимся о клиентах – настроим «зеленый» порт:

/ip address add interface="ether4" address="192.168.0.1/24"

и включим NAT на «красном»:

/ip firewall nat add out-interface="ether5" chain="srcnat" action="masquerade"

Офис счастлив, так как с этого момента интернет работает на всех компьютерах локальной сети, у которых:

  • IP-адрес принадлежит сети 192.168.0.0/24,
  • в качестве шлюза указан IP-адрес «зеленого» порта нашего маршрутизатора, т. е. 192.168.0.1,
  • в качестве DNS-серверов указаны провайдерские DNS-серверы.

PPTP-подключение

Рассмотрим другую популярную схему подключения к интернету. Предположим, что мы подключены к «серой» сети провайдера с такими параметрами:

  • IP-адрес: 10.0.200.2,
  • Маска: 255.255.255.0 (или /24),
  • Шлюз: 10.0.200.1.

В «серой» сети провайдера есть какие-то бесплатные ресурсы, и мы желаем ими пользоваться. А для доступа в интернет провайдер требует установить PPTP-соединение с сервером 10.0.0.1, используя логин MyLogin и пароль MyPassword.

DNS-серверы используются те же, что и ранее, т. е. 194.85.61.20 и 193.232.130.14.

С точки зрения «зеленого» интерфейса, эта схема не отличается от уже описанной. А вот «красных» интерфейсов у нас будет два: один из них – это Ethernet в «серой» провайдерской сети, второй – PPTP-соединение с доступом в интернет.

Итак, настраиваем первый «красный» интерфейс:

/ip address add interface="ether5" address="10.0.200.2/24"
/ip route add dst-address="10.0.0.0/8" gateway="10.0.200.1"
/ip dns set primary-dns="194.85.61.20"
/ip dns set secondary-dns="193.232.130.14"

Обратите внимание на изменение в схеме маршрутизации. Ранее мы указывали шлюз по умолчанию, на который «заворачивался» весь трафик. Теперь у нас шлюзом по умолчанию будет другой конец PPTP-соединения, когда оно будет установлено. А до этого момента, нам все-таки нужно знать, как дойти до PPTP-сервера и до бесплатных ресурсов провайдера. Поэтому в команде /ip route add появился параметр dst-address.

Теперь создаем второй «красный» интерфейс – PPTP-соединение:

/interface pptp-client add name="MyPPTP" connect-to="10.0.0.1" user="MyLogin" password="MyPassword" add-default-route="yes"
/interface enable "MyPPTP"

И, наконец, настраиваем NAT на обоих «красных» интерфейсах:

/ip firewall nat add out-interface="ether5" chain="srcnat" action="masquerade"
/ip firewall nat add out-interface="MyPPTP" chain="srcnat" action="masquerade"

miniROUTER в мини-офисе

miniROUTER оснащен пятью независимыми Ethernet-портами. Один из них задействован для подключения к провайдеру. А оставшиеся можно объединить так, чтобы они работали, как обычный коммутатор. Значит, если в офисной сети не более четырех компьютеров, то никакое другое сетевое оборудование приобретать не нужно.

Для такого объединения нужно выбрать любой свободный порт (пусть это будет ether4) в качестве главного (master), а остальные порты прописать в подчинение (slave) ему таким образом:

/interface ethernet set "ether1" master-port="ether4"
/interface ethernet set "ether2" master-port="ether4"
/interface ethernet set "ether3" master-port="ether4"

RouterOS на офисном шлюзе, часть 2: Обновление
  • Гофролист

    Продажа профилированного настила, гофролиста. Сравните цены

    zavod-profil.ru

Спонсоры данной статьи


Категория: Авторские статьи | Добавил: -=shurf=- (03.09.2010)
Просмотров: 8613 | Теги: dns, gateway, IP, раздача интернета, микротик, PPTP, маршрутизация | Рейтинг: 5.0/1

Настройка Mikrotik
Mikrotik - winbox or console
Мануал по настройке программно...
Настройка PPP интерфейсов и се...
Mikrotik Burst Limit и ABills
Серверные сценарии ч.2
Mikrotik - два провайдера, бал...
Mikrotik - cкидання пароля ()
Mangle
OSPF
Службы, протоколы и порты

Всего комментариев: 0
Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход ]
Профиль
Привет: Гость

Сообщения:

Гость, мы рады вас видеть. Пожалуйста зарегистрируйтесь или войдите!

Реклама

Наш опрос
Вы нашли на сайте нужную информацию?
Всего ответов: 55

Нашел ошибку?
Система Orphus

Статистика

Онлайн всего: 2
Гостей: 2
Пользователей: 0



Бесплатный хостинг uCoz